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Access 2013: The Administrator

Advanced Access Objectives
In this lesson, you will learn how to: 
1. Append new Records to an existing Table.
2. Create an Action Query to Update the data 
for selected Records in a Table.
3. Use an Action Query to Make a new Table 
and copy selected Records to that new Table.
4. Create a Delete Query and practice with a 
copy of an existing Table.

Strategies for Archiving 
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1. Readings
Read Lesson 10 in the Advanced Access 
guide, page 275-307.

Project
Several Action Queries that Append, 
Update and move the data in the Tables. 

Downloads
FrontRowVideo Adv10.accdb
tblMoviesNEW.xlsx
BBL Adv ver10.accdb

2. Practice
Do the Practice Activity on page 308.

3. Assessment
Review the Test questions on page 308.

Menu Maps
From the External Data Ribbon.
1. Microsoft Access->External Data ->Import & Link-> Excel, page 282

From the Create Ribbon.
Create->Queries->Query Design-> Find Duplicates Query Wizard, page 286

From the Report Design Ribbons.
2. Query Tools ->Design->Query Type-> Update, page 300
3. Query Tools ->Design->Query Type-> Make Table, page 302
4. Query Tools ->Design->Query Type->Delete, page 305

External Data Ribbon

Query Design Tools->Design

Lesson 10 : Strategies for Archiving
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Lights, Camera, Action!
Action Queries can change the data in the Tables. For example, we created an Update Query to find any movie released before the 
year 2000 and set the rental price (RentalPriceID). The other Action Queries include Append (add more Records), Delete (subtract 
Records), and Make Table (Copy the Records from a Query into a new Table.) 

This lesson will use Action Queries to 
import new movies into the movie 
Table and check for duplicates.

Our Mighty Access database needs a 
strategy for archiving the Records. 
There are several Action Queries that 
can simplify that task. Let's look at a 
plan.

Microsoft Office Access: Example of an Action Query
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What is the Plan? 
The first goal is to import the new movie titles into the 
movie Table with an Append Query. The archive 
strategy has several steps as well. 

Import New Records into Access
Import a spreadsheet into Access
Append the new Records to tblMovies.

Revise the Table: tblMovieTitles
Add new Fields: Archived, Status, Memo.
Add the Fields to the Movies Form.

Create a Update Query: ArchiveMovieUQ
Add tblMovies as the Record Source. 
UPDATE the Archive Field to Yes.

Run a Make Table Query: ArchiveMovieMT
Save the UPDATE Query as a MAKE TABLE.
Create a new Table: tblArchiveMovies.

Use Action Queries to Test the Data
Create an UNMATCHED Query.
Create a FIND DUPLICATES Query.
Create a DELETE Query. 
That's a good plan.

Example of an Action Query in Design View
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start -> Microsoft Access 2013.
Access will prompt you to open a database. 
Select: FrontRowVideo Adv10.accdb

The database, FrontRowVideo Adv10.accdb, was 
developed in the previous lessons. You do not have to 
download a new sample. You can continue with your 
own database if you wish. 

This lesson uses an Action Query to import new 
movies into the movie Table. There is a sample 
spreadsheet with the additional movie titles that you 
should download before you begin, too.
Download the spreadsheet: tblMoviesNEW.xlsx

Keep going....

Memo to Self: Databases need to Read and Write. 
Click Enable Content if you see the Security 
Warning. 

Start -> Microsoft Access 2013
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Know Your Data 
Try This: Review the Database
Open the Navigation Pane.
Go to All Access Objects.

The Front Row Video database has the following:
Eight Tables: tblCustomers, tblGenre, tblMovieRented, 
tblMovies, tblMovieSearch, tblRating, tblReceipt and 
tblRentalPrices.

Twelve Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MovieRentalPriceUQ, 
MoviesByYearSQ, MovieSearchSQ, MovieSQ, 
RatingSearchSQ, ReceiptSQ, rptMovieRentedSQ, 
rptOverdueSQ rptReceiptSQ and tblMovies_Crosstab.

Eight Forms: Customers,  MovieRentedSubform, 
Movies, MoviesbyRatingChart, MovieSearch, 
MovieSearchSubform, Receipt and Switchboard.

Six Reports: Customer Name, Movies by Genre, Movies 
by Year, rptMovieRented-POS, rptOverdue, and 
rptReceipt-POS. 

One Macro: OpenSearchMovie

All Access Objects
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.1 Create a Table: Import External Data into Tables (Excel spreadsheet)

Import Data into Access:
Review the New Information
Look before you leap. Many companies send 
spreadsheets with updated product information. 
Before you import any data in Microsoft Access, 
you should review it. 

1. Try it: Review the New Data
Start Microsoft Excel.
Go to File->Open.
Browse for the file: tblMoviesNEW.xlsx. 
Please open the spreadsheet. 

What Do You See? There are 20 new movies in 
this spreadsheet. The first Row is the Header 
Row. It includes the following Fields: Movie, Year, 
Rating, Genre and Stars.

What Should You Be Looking For? These Field 
names MATCH the ones in the Access Table, 
tblMovies.

Close the spreadsheet.
The next step is in Access. 

Microsoft Excel->Home
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Records: Append Records from External Data (Excel) 

Import Data into Access: 
Get External Data 
There is an Import Spreadsheet Wizard that walks you 
through the process of importing data into Access. The 
steps ask to find the data and identify the Header Row

2. Try it: Get External Data
The Front Row Video database is open.
Go to External Data ->Import & Link-> Excel.

Try This, Too: Browse for the Data Source
Select: tblMoviesNEW.xlsx

Try This, Too: Specify How to Store the Data
The three import options include:
Import into a new table
Append (add) records to a table
Link to an external table
Select: Append and choose a Table: tblMovies.

Click OK. 

Keep going...

Microsoft Access->External Data ->Import & Link-> Excel
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Records: Append Records from External Data (Excel) 

Append Data to a Table:
Select a Worksheet
3. Try it: Select a Worksheet or Range
An Excel workbook can have more than one 
spreadsheet or Named Range. 

The Import Spreadsheet Wizard will ask you to 
confirm which Worksheet has the data. You 
can select a Worksheet or a Named Range. 

Select a worksheet: New Movies.

What Do You See? The sample data for 
tblMovieTitles looks like the spreadsheet we 
just reviewed. So, we are good to go.

Click Next. 

Keep going...

Microsoft Access->External Data ->Import & Link-> Excel
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Records: Append Records from External Data (Excel) 

Append Data to a Table:
Identify the Header Row
This step compares the Fields in the External 
Data to the Fields in the existing Table. The 
Field Names AND Data Types need to 
MATCH. Text goes with Text. Numbers go 
with Numbers.

4. Try it: Confirm the Header Row
This sample spreadsheet has a Header Row. 
The Header Row contains all of the Field 
Names: Movie, Year, Rating, etc.

Everything looks good.
Click Next. 

Try This, Too: Import to Table
Confirm the Table: tblMovies.
Click Finish to close the Import Wizard.
If the Save Import Steps window is open you 
can simply close it

So, did the Wizard append (add) these movies 
to the right Table?

Microsoft Access->External Data ->Import & Link-> Excel
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Records: Append Records from External Data (Excel) 

Append Data to a Table:
Review the Data
5. Try it: Review the Table Records
Go to All Access Objects->Tables.
Open a Table: tblMovies.
The Table should open in Datasheet View.

Know Your Numbers! This Table began with 401 
Records. There are now 421 Records, so all 20 
new movies were imported from the Excel 
spreadsheet.

What Do You See? There are two copies of the 
same movie, The Hunger Games (2012.)
Apparently, there are duplicates in this Table.

Yeah, there's always more work to do, isn't there? 
Luckily, there is a Query Wizard that will help you 
find the repeats. 

Close the Table. Let's create the Find Duplicates 
Query.

All Access Objects->Tables
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping Within a Query (Find Duplicates) 

Append Data to a Table:
Find Duplicates Query
"There's a Query for that!" Access has a Find 
Duplicates Query Wizard that will walk you 
through the steps.

6. Try it: Find Duplicates Wizard
Go to Create->Queries->Query Design.
Click on Find Duplicates Wizard

Click OK. The Query Wizard should begin.

Create->Queries->Query Design-> Find Duplicates Query Wizard
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping Within a Query (Find Duplicates) 

Find Duplicates Query Wizard 
7. Try it: Select a Record Source
Table or Query: tblMovies.
Click Next.

Try This: Select the Field with Duplicates 
Select an Available Field: Movie.
Click Next.

Skip This: Select Another Field

Now, Do This: Name the Query
Enter a name: Find duplicates for tblMoviesSQ.

Click Finish. 

Create->Queries->Query Design-> Find Duplicates Query Wizard
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping Within a Query (Find Duplicates) 

Find Duplicates Results 
8. Try it: Review the Query Results
The Find duplicates for tblMoviesSQ  
Query found two copies of one movie, "The 
Hunger Games."  

What Else Did You Notice? This Query 
does not allow you to expand the Rows to 
see both movies. If you could see both you 
would delete one. 

So, how do you handle duplicates? 
If the duplicate is a new Record that hasn't 
been used in any Receipts, you can go to 
tblMovies and delete it. 

If the duplicate was already used in a 
Receipt, you need to edit the Receipt to 
use the correct movie before you delete 
the duplicate movie. 

Still, this little Query searched through the 
Movie Field and found two that matched. 
How did it do that?

Let's see for ourselves.

Create->Queries->Query Design-> Find Duplicates Query Wizard
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.2 Modify a Query: Hide Fields

Find Duplicates Query Design 
The Query Design is fascinating. Once you see how it 
works, one can only marvel at the simplicity.

9. Try it: Review the Query in Design View
The Find duplicates for tblMoviesSQ Query is open.
Go to Home->Views->View->Design View.

What Do You See? This Query has one Table: tblMovies. 
There are only three Fields in the QBE Grid. The Totals 
Row is available. Queries read from left to right. So this 
Query is asking three questions. 

Movie Field: Movie asks "Which movie? Is this the first 
time we've seen this movie in the list?" This Field looks in 
tblMovies for the First time a movie appears.

NumberofDups: Movie asks "Is there more than one copy 
of this movie?" This Field looks in tblMovies and Counts the 
Records. The Criteria is (Greater than) >1.

Movie asks "Are we the same? Ok, let's Group!" This Field 
Groups the movies that match.

Show or Hide: The last Column in the Query does not have 
a check mark for Show. So, this Field will not be seen in the 
Query results. It is hidden. Please Close the Query. 

Home->Views->View->Design View
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Records: Delete Records

Deleting Data: Consider This! 
1. Consider This: Should You Delete Data? 
Deleting data is not a good idea in a relational 
database. When you create a Receipt in our 
database, you need information from five Tables. 
Consider this scenario.

Say you deleted the Movie, "Brave" from tblMovies. 
Say the Primary Key, MovieID, for this Movie was 
407. 

Now, you want to run a Report that looks up all of 
the Receipts. Any Receipt that had MovieID 407 will 
be incomplete. There is no data because that Key is 
missing. 

This is not good.

The preferred method is to Archive a Record by 
marking it as Archived, Done or Obsolete.

Microsoft Access: Example of the warning message when a Record is deleted
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.1 Create a Table: Create a Copy

Create an Archive Program 
2. An Alternative Approach: Archive the Data
The following pages will look at ways to archive old 
data. Here is a overview.

Revise the Movie Table: tblMovies
There are three Fields that should be added to the 
Movie Table to make this a really useful database. 

First, there will be a Yes/No Field that indicates if the 
Movie is Archived. 

Second, there will be a Multi-Value Field that 
documents the status. 

Third, we'll add a Long Text Field.

Create a Make Table Query
The Archived Movies will be selected and copied into 
a new Table.  

Create a Delete Query
The last Action Query deletes the Archived Movies 
from tblMovies.

So, when you are ready...

Microsoft Access: Example of the completed Make Table Query
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.4 Protect and Maintain a Database: Backup Databases (Save a Copy)

Save a Copy of the Table 
Good database administrators do not lose data. 
Before editing a Table in any working database, it 
is a wise precaution to create a backup copy of 
that Table.

3. Try it: Save a Copy of the Table
The Movie Table may still be open, if not.
Go to All Access Objects->Tables.
Open a Table: tblMovies.

Try This, Too: Save a Copy
Go to File->Save As->Save Object As.
Enter a name: Copy of tblMovies 4-16-2014,
where 4-16-2014 is the current date of the backup 
copy. 

Click OK. Now, click on the Home Ribbon to see 
the database Objects. 
Close the Copy of tblMovies 4-16-2014 Table.

There is a current backup copy of the data. 

Now...we can keep going...

File ->Save As->Save Object As
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.4 Create and Modify Fields: Add Fields to Tables

Add New Fields to the Table 
The Movie Table needs a Field that indicates a 
Record should be archived and marked as no 
longer part of the daily rentals. The Archived Field 
can be as simple as Yes/No.

Before You Begin: Open the Table
Go to All Access Objects->Tables.
Select a Table: tblMovies.
Go to Home ->Views->View->Design View.
The Table Tools should be available. 

4. Try This: Add a New Field
Field Name: Archived
Data Type: Yes/No

What Do You See? By default Microsoft Access 
uses a check box for this Control. A "Yes" answer 
means True or On.  A "No" answer means False 
or Off. 

Keep going...

Home ->Views->View->Design View
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.4 Create and Modify Fields: Add Fields to Tables (MultiValue Fields)

Add a MultiValue Field
A MultiValue Field lets Users select more 
than one answer to a question. You can use a 
MultiValue Field to document why a movie was 
Archived. 

5. Try it: Add a MultiValue Field
Field Name: Status.
Data Type: Lookup Wizard.

What Do You See? The Lookup WIzard will 
prompt you for the following:

Record Source: I will type in the values that I 
want. Click Next. 

Type in the Values:
Damaged
Lost
No Sale
Do Not Reimage.
Click Next. 

Label: Status.

Click Finish. Keep going...

Table Tools ->Design
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.4 Create and Modify Fields: Add Fields to Tables (MultiValue Fields)

Review the MultiValue Field 
The Lookup Wizard walked us through the task of 
creating a Lookup List. There are two additional 
choices in the last step of the Wizard: Limit to List 
and Allow Multiple Edits. By default, these options 
are not selected.

Where would you change them? Look in the Field 
Properties: There are two Tabs! We usually edit 
the General Properties. There is also a Lookup 
Tab. Well, let's look.

6. Try it: Review the Field Properties
Select a Field: Status.
Go to Field Properties-> Lookup.

What Do You See? The Properties are:
Display Control: Combo Box
Row Source Type: Value List.
Row Source: 
Limit to List: Yes (Users can't add to the list).
Allow Multiple Values: Yes (Pick more than 1).
Allow Value List Edits: No.

Field Properties-> Lookup
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.2 Format a Table: Change Data Types and Formats (Rich Text)

Add a Comments Field 
Another useful Field is the Long Text. Long Text 
Fields can hold a lot. In fact, Long Text Fields 
can store 2GB of data. There are two Field 
Properties worth considering: Text Format and 
Append Only. By marking the Field Append 
Only, Users can ADD to the data, but they 
cannot DELETE the previous entries. 

7. Try it: Add a Memo Field
Field Name: Comments.
Data Type: Long Text.

Try This, Too: Edit the Field Properties
Go to Field Properties->General.
Text Format: Rich Text.
Append Only: Yes

Save and Close the Table, please.

Memo to Self: Selecting "Yes" for the Append 
option also Tracks the history. The history is 
available when you add this Field to a Form. You 
can right-click the Long Text Field in Form View 
to see the tracking.

Table Tools ->Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls

Add the Fields to the Form 
The Movie Table is updated. Done and done. We 
can add the new Fields to the Movie Form, now. 
You can also improve the layout and placement of 
the Controls if you wish. 

8. Try it: Add the Field to a Form
Open the Movie Form in Design View.
Go to Form Design Tools ->Design->Tools.
Click on Add Existing Fields.
Add three Fields to the Form:
Archive
Status
Comments

Go ahead, format the Form Header. 
Save your changes and keep going...

Form Design Tools ->Design->Tools->Add Existing Fields
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Test the New Form Fields 
Before You Begin: Change the View
Go to Form Design Tools ->Views->View.
Select a View: Form View.

Still Before You Begin: Find a Movie
Click on the Movie Field.
Go to Home->Find->Find.
Find What: Amityville II: The Possession. 
Match: Any part of Find.
Click Find Next to go to that movie.

9. Try it: Test the New Form Fields
Check: Archived.
Change the Status: No Sale, Do Not reimage.
You can add some sample text to the 
Comments Field.
Please Close the Movies Form.

The data should be updated in tblMovies. You 
could find all of the movies that were released 
before 1990 and mark them as Archived. 

Or...you can use an Action Query to update 
them all at once. Let's go for the Action Query. 

Form Design Tools ->Views->View->Form View
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Record: Update Records With an Action Query

Select the Oldies 
The goal in this next step is to create an Update 
Query that will mark all of the Movies released 
before 1990 as "Archived." The best place to start is 
to make a Select Query and see if it finds the right 
Movies. When it works we'll save the Select Query 
as an Update Query. 

1. Try it: Create a Select Query
Go to Create ->Queries ->Query Design.
You will be prompted by the Show Table. Select a 
Table: tblMovies.
Click Add and Close the Show/Table Window.

Try This, Too: Add Fields
Add these Fields to the QBE Grid:
MovieID, Movie, Year, Archived, Rating, Genre, 
Stars and RentalPriceID.

Yep, And This: Add a Criteria
Select a Field: Year.
Enter a Criteria: <1990

When you Run this Query you should find 73 
movies that have this Criteria. 

Keep going...

Create ->Queries->Query Design
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Record: Update Records With an Action Query

Update the Oldies 
The same Query that selected the Movies can be 
changed into an Action Query and Update the 
Archive Field to "Yes." Here are the steps.

Before You Begin: Change the View
Go to Home->Views-View->Design View.

2. Try it: Create an Update Query
Go to Query Tools ->Design->Query Type.
Select a Query Type: Update.

What Do You See? There will be a new Row in 
the QBE grid: Update to.

Try This, Too: Enter the Update Value
Go to a Field: Archived.
Update to: Yes.

Better Do This, Now: Save the Query
Go to File->Save.
Enter a name: ArchiveMovieUQ,
where UQ means Update Query.

Keep going...

Query Tools ->Design->Query Type-> Update
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Record: Update Records With an Action Query

Run the Update Query 
An Update Query is an Action Query. When you run 
the Update Query, you will be notified that this 
Action will change the Records and that there is No 
UNDO. 

3. Try it: Run the Update Query
Go to Query Tools ->Design->Results-> Run.

What Do You See? This Query will update 73 Rows 
in tblMovies. That number matches the one we saw 
when we tested the Query as a Select Query. Click 
Yes to Run the Update.

Trust But Verify: Confirm the Updated Rows
Go to All Access Objects->Table.
Open a Table: tblMovies.

What Do You See, Now? Did the Update Query 
change the Archived Field to Yes for the Movies 
released before 1990?

Please Close tblMovies and return to the 
ArchiveMovieUQ Query.

Query Tools ->Design->Results-> Run
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.2 Modify a Query: Rename Queries

Copy to a New Table 
The Update Query, ArchiveMovieUQ, will also 
work as another type of Action Query: A Make 
Table Query. The Make Table Query selects the 
Records that match the Criteria and copies those 
Records into a new Table.

4. Try it: Create a Make Table Query
The ArchiveMovieUQ Query is still open.
Go to Query Tools ->Design->Query Type.
Select a Query Type: Make Table.

What Do You See? You will be prompted to name 
the new Table.
Enter the Table Name: tblArchiveMovies.
Click OK to Run the Make Table Query.

Do This, Now: Save the Make Table Query
Go to File->Save Object As.
Enter the name: ArchiveMovieMT,
where MT means this is a Make Table Query.

Keep going...

Memo to Self: By default, this new Table will be 
made in the Current Database.

Query Tools ->Design->Query Type-> Make Table
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Run Action Queries (Make Table)

Review the Data 
Did all of the Records get copied to the new Table 
when we ran the Make Table Query?

5. Try it: Review the Data
Go to All Access Objects->Tables.
Open a Table: tblArchivedMovies.

What Do You See? There should be 73 Records in 
tblArchivedMovies.
Close tblArchivedMovies.
OK. Save and Close ArchiveMovieMT.

Little Summary: There are two Queries that can be 
modified and reused for archiving.

ArchiveMovieUQ: This Query uses a Criteria to 
Filter the Records by Year. It is an Update Query 
that will change the Archived Field to "Yes" for all of 
the selected Records. 

ArchiveMovieMT: This Query uses the same 
Criteria to Filter the Records by Year. The Records 
that match the Criteria are copied into a Table 
named tblArchivedMovies. 

Query Tools ->Design->Query Type-> Make Table
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Create Delete Queries

The Last Action Query 
A Delete Query does exactly what the name spells 
out: It deletes data. As mentioned earlier, deleting 
data is not the best practice for a database 
administrator. However, this option may be better than 
marking bad records as archived.

The following example will use a copy of the Movie 
Table to test the Delete Query. 

1. Try it: Create a New Query
Go to Create ->Queries ->Query Design.
You will be prompted by the Show Table. 
Select a Table: Copy of tblMovies 04-16-2014.
Click Add and Close the Show/Table Window.

Try This, Too: Add Fields
Add these Fields to the QBE Grid: MovieID, Movie, 
Year, Rating, Genre, Stars and RentalPriceID.

And Try This: Add a Criteria
Select a Field: Year.
Enter a Criteria: <1990

Do This, Now: Run the Select Query
Did this Query select 73 Records?

Create->Queries->Query Design
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Create Delete Queries

Run the Delete Query 
So the Select Query works. Now, you can change it 
into a Delete Query.

Before You Begin: Change the View
Go to Home ->Views->View.
Select a View: Design View.

2. Try it: Create a Delete Query
Go to Query Tools ->Design->Query Type.
Select a Query Type: Delete.

Try This, Too: Run the Delete Query
Go to Query Tools ->Design->Results-> Run.

What Do You See?  You will be prompted that you 
are about to delete 73 Rows. You are also reminded 
that there is no UNDO. This is permanent data 
heaven.

Click Yes to delete the data from the Copy of 
tblMovies 4-16-2014, Table.

So, let's go see what's left in this Table.

Query Tools ->Design->Query Type->Delete
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Create Delete Queries

Review the Data 
3. Try it: Review the Data
Go to All Access Objects->Tables.
Open a Table:Copy of tblMovies 4-16-2014.

Try This, Too: Sort the Records
Select a Field: Year.
Go to Home ->Sort & Filter->Ascending.

What Do You See? There were 420 Records in 
Copy of tblMovies 4-16-2014. The Delete Query 
deleted 73 movies, leaving 347. 

Well, for what it is worth, the movies were 
effectively deleted as promised.
Close the Copy of the Movies Table.

Do This, Now: Save the Delete Query
Go to File->Save.
Enter a name: DeleteArchiveMoviesDQ.
Close the Delete Query. 

Home ->Sort & Filter->Ascending
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Summary 
This discussion began by importing the new movies into 
the Movie Table and checking for duplicates.

We also created several Action Queries to simplify the 
task of archiving the old movies.  The steps included 
adding new Fields to the Movie Table: Archived, Status 
and and Memo. We also added those Fields to the 
Movies Form.

The Action Queries included:
An Update Query,  ArchiveMovieUQ to UPDATE the 
Archive Field to Yes for the old movies.

A Make Table Query, ArchiveMovieMT, to copy the 
Archived Records into a new Table: tblArchiveMovies.

Two new Action Queries to Test the Data: 
Find duplicates for tblMoviesSQ
ArchiveMovieMT

Now that was a very good lesson. You done good!
Go get the cookies!
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4. Which of the following is true about a 
Multi-Value Field? 
(Give all correct answers.)
A. Lets users select more than one answer
B. The creator types a list of values to be 
chosen from
C. Users can be allowed to add new items 
to the list
D. Users are always limited to the items in 
the list
Tip: Advanced Access, page 294, 295

5. Which of the following is true about the 
Memo Field?
A. It can only hold 40 characters
B. It can hold 2 GB of data
C. Users can only add to the existing data
D. Users can be allowed to delete the 
existing data
E. When the Memo is set to Append only, 
users can add to but cannot delete existing 
data
Tip: Advanced Access, page 296

1. Which are options for importing External 
Data? (Give all correct answers.)
A. Import into a new Table
B. Link to an external Table
C. Append (add) Records to a Table
Tip: Advanced Access, page 282

2. Access has a Query specifically for finding 
duplicate records.
A. True
B. False
Tip: Advanced Access, page 286

3. Which of the following is true about 
Records? (Give all correct answers.)
A. Deleting is not recommended because it 
removes a Primary Key number
B. Preferred method of removing Records is 
to Archive it
Tip: Advanced Access, page 290

Lesson 10: Strategies for Archiving
Try This: Do the following steps
1. Open your Brown Bag Lunch database 
Or, you may download BBL Adv ver10.accdb
2. Edit the Products Table, tblProducts, in Design View. Add the 
following Fields:
Field Name: Discontinued, Data Type: Yes/No
Field Name: Reason, Data Type: Memo
Save the changes and close the Table.
3. Create a Select Query in Design View. Select tblProducts as 
the Record Source. Add all of the Fields to the QBE Grid. Run 
the Query to test it. Return to the Design View.
4. Add a Criteria to the Type Field: “Snacks” Run the Query to 
test it. Return to the Design View.
5. Change this Select Query to an Update Query. 
Update Discontinued to Yes. 
Update Memo to: "Not interested in this product."
6. Save the Query as ProductDiscontinedUQ.
7. Run the ProductDiscontinuedUQ Update Query and confirm 
that the data in the Products Table was changed. 
8. Close the Update Query.
9. Close the Brown Bag Lunch database.

Test YourselfPractice Activities
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