
Advanced Charts
Create and Modify Advanced Charts
Students will be able to:
Concept: Analyze data with advanced charts
Task: Create and modify advanced charts
Create and modify Advanced Charts, including:
Combo Charts, Map, Treemap, Sunburst, Funnel, 
Histogram, Waterfall, and Box and Whisker
Change Data Type to Map data
Modify Chart colors
Explain the uses of the advanced chart types

Excel Expert Certification Exam Objectives
Create and modify dual axis charts
Create and modify charts including Box & Whisker, 
Combo, Funnel, Histogram, Map, Sunburst, and 
Waterfall charts



VISUALIZING DATA

Unit Check List
Complete the Lesson
Advanced Charts: Pages 93-122

Task
Complete the following: Format several 
spreadsheets as advanced charts: Hierarchy, 
Statistic, Information, Combo and Map.

Downloads
Advanced Charts Unit Sample.xlsx

Test Yourself: 
Unit Review Pages 121-122

Chart Ribbon (left)
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Menu Maps
1. Insert-> Charts-> See All Charts->Combo

2. Insert-> Charts-> Map-> Filled Map

3. Insert-> Charts-> Insert Hierarchy Chart-> Treemap Chart

4. Insert-> Chart-> Hierarchy Chart-> Sunburst

Insert Ribbon (left)



PUTTING EXCEL TO WORK

Let’s Open Excel
In this Unit we will be creating and modifying 
advanced chart types.

Please download the sample spreadsheet:
Advanced Charts Unit Sample.xlsx

There are a several sheets in the workbook:
• Speed and Crashes Combo
• WHO Traffic Deaths Map
• Potholes Treemap
• MI Divisions Funnel
• Crash Avg Histogram 
• Project Cost Waterfall
• Bridge Age Box
• Winter Crash Sunburst
• Crash_PivotTable
• Crach_Data

Screen image of the sample workbook
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ORGANIZING THE DATA

Excel includes a number of advanced chart 
types for displaying complex, statistical or 
hierarchical data visually. These charts go 
beyond the functions of the standard column, 
bar, pie and line charts.
Advanced chart types include map, treemap, 
sunbursts, histogram, combo, box and 
whisker, and funnel charts.
Often, these charts require data to be in 
certain format or organized a particular way 
for the chart to render accurately. As with all 
charts, using the right chart for the data and 
the visualization is crucial.
In this Unit we will learn about some advanced 
Chart types and their uses. We will create and 
modify advanced charts as well.
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REVIEW: THE PARTS OF CHART

All charts show data in a visual format. The type of chart 
should be suited to the type of data and the meaning 
that the audience should get from the data.
Different chart types have common elements. Bar, 
column, Historgram, and other similar types share the 
same structure: axis, data, wall, title.
Pie charts share similarities with sunburst, treemap, and 
map charts. They include data as a whole, include a 
chart area (background), but lack axes.
Understanding the components of a chart can help with 
chosing and modifying a chart for the best impact.
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INSERT A COMBO CHART

A chart can compare the relationship between 
two types of data. For example, we could chart 
the relationship between the speed and the 
number of crashes. 
Note that transportation departments usually 
refer to them as crashes, not accidents.

Task: Create a Combo Chart
1. Go to the Speed and Crashes sheet
2. Select the data in Columns D and E
3. Go to Insert-> Charts-> See All Charts (the more 
options arrow in the bottom right of the Charts 
Group). The Insert Chart dialogue box will open.

Keep going...

MDOT: Michigan Department of Transportation
Link: https://www.michigan.gov/mdot/

Insert-> Charts-> See All Charts
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Create and Modify Advanced Charts 
4.1.1 Create and Modify Dual Axis Charts

Microsoft Excel for Mobility  Analysts     Page 98



COMBO CHART, CONTINUED

A combo chart contains two different types of 
charts in one chart. The chart will use two data 
sets. A secondary axis can show a different 
set of data values.

Task: Set up a Combo Chart
The Insert Chart dialogue box is open.
Go to the All Charts tab.
1. Go to the Combo category.
2. Choose Clustered Column and Line chart.
3. Change the SPEED series to Line. Check the box 
for Secondary Axis
4. Change the YR CRAH AVG Series to Clustered 
Column.
What Do You See? There is a preview of the chart.
5. Click OK to insert the chart

Insert-> Charts-> See All Charts
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REVIEW THE COMBO CHART

A new Combo Chart was placed on the 
spreadsheet next to (or on top of) the data. 
Let’s take a moment to finish the chart.

Task: Review the Combo Chart
1. Move the chart and resize it.
Use the Chart Tools Icons beside the chart to make 
the following changes:
2. Edit the Title: Speed and Crashes Combo
3. Edit the Chart Elements: Select both Horizontal 
and Vertical Axis Titles.
4. Edit the Vertical Axis Title: Average Speed.
5. Edit the Horizontal Axis: Number of Crashes.

What Do You See Now? The chart columns show 
the number of crashes at each intersection. The line 
shows the increase in speed.
We can see there is some relationship between an 
increase of speed and an increase in crashes.
Interesting.

Screen image of the Chart Tools
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CREATE A MAP CHART

A map chart uses geographical information to 
color a map based on the values. Excel can 
work with data for counties, countries, states, 
and more.

Task: Create a Map Chart
1. Go to the WHO Traffic Deaths sheet
2. Select A2 to A175. 
Go to Insert-> Charts-> Map-> Filled Map.
3. Excel may prompt for permission to access the 
internet via Bing to retrieve geography data.
If so, say Yes.

Keep going,,,

WHO: World Health Organization
Link: https://www.who.int/

Insert-> Charts-> Map-> Filled Map
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MAP CHART, CONTINUED

A map chart uses geographical information to 
color a map based on the values. Excel can 
work with data for counties, countries, states, 
and more.

Task: Review the Map Chart
1. Move the chart and resize it.
2. Edit the Title: Traffic Deaths by Country
3. Edit the Chart Elements: Unselect the Legend.

What Do You See? Excel has created a map chart 
that shows darker shades of blue for areas with 
higher rates of death.
What Else Do You See? Angola and Greenland are 
not colored. These countries are not included in the 
dataset.

The More You Know: To revert data type from 
Geography back to text, select the cell or cells and 
right click. Choose Data Type--> Convert to Text.

Insert-> Charts-> Map-> Filled Map
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MAP CHART: FORMAT DATA SERIES

Excel often colors with the default blue palette. 
This does not provide an effective contrast in 
colors for our map data. 
Changing the colors can make the data more 
meaningful at a quick glance.

Task: Format the Data Series
The WHO Traffic sheet is still open. The Chart is 
selected.
1. Go to Chart Format-> Chart Area
Note: The Drop down box will display the name of a 
selected area of the chart. Open the dropdown menu to 
see the chart elements.
2. In the dropdown menu, choose Series "Estimated road 
traffic death rate per 100 000 population"

What Do You See? The data series in the map chart 
were selected. The data in Column A and Column B are 
selected as well.

Keep going…

Chart Format--> Chart Area
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MAP CHART: FORMAT DATA SERIES OPTIONS

The Data Series for a map can use max, min, and 
midpoint as the values to show the relationships of 
the data. Choosing the colors for the three points 
should highlight the relationship. The colors will be 
blended for points in between.

Task: Edit the Data Series Options
1. Click Format Selection.
What Do You See? The Format Series Pane will open on 
the right side of the screen. There are three tabs from left 
to right: Fil l& Line, Effects and Series Options.

2. Click on the Series Options button
3. Expand the Series Color options
4. In the drop down box, choose Diverging (3 color)
5. Set the colors: Yellow for minimum, Orange for 
Midpoint, and Dark Red for maximum.

Now the data is more vivid.

Chart Format--> Current Selection->Format Selection
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CREATE A TREEMAP CHART

A Treemap chart displays hierarchical data. 
The data is shown in categories and sub-
categories as nested rectangles.

Task: Create a Treemap Chart
1. Go to the Potholes Report sheet.
2. Select cells B2 to I4. 
3. Go to Insert-> Charts-> Insert Hierarchy Chart.
Select a Chart: Treemap Chart.

What Do You See? The chart has given each year a 
color. The rectangles are labeled as Website or 
Hotline with larger rectangles each year, reflecting 
the increase in reporting.

Insert-> Charts-> Insert Hierarchy Chart-> Treemap Chart
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CREATE A FUNNEL CHART

A funnel chart is used to show values through 
stages of a process. It is most often used to 
represent the sales funnel of potential contacts 
through to actual sales. It can be used for 
other comparisons as well.
For our data set we will see a funnel of 
geopolitical divisions from least to most as a 
representation of funnel chart data.

Task: Create a Funnel Chart
1. Go to the MI Divisions sheet.
2. Select the data in A1 to B3
3. Go to Insert-> Chart->Waterfall, Funnel, Stock, 
Surface, or Radar Chart
4. Select Funnel.

What Do You See? The Funnel chart shows the 
relationship between the different geopolitical 
organizations. There are counties (fewest), charter 
townships (middle value), and townships.

Insert-> Chart->Waterfall, Funnel, Stock, Surface, or Radar Chart
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CREATE A HISTOGRAM

A Histogram is a chart that displays frequency 
data. Frequency refers to how often a data 
point appears in the data set. A histogram is 
frequently used in statistical analysis.

Task: Create a Histogram
1. Go to the Crash Avg Histogram sheet.
2. Select column H
3. Go to Insert-> Chart-> Insert Statistic Chart-> 
Histogram
What Do You See? Excel has distributed the data 
into 4 bins.

Keep going...

Insert-> Chart-> Insert Statistic Chart-> Histogram
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HISTOGRAM, CONTINUED

To display the frequency data, a Histogram 
chart sorts the datapoints into bins. The 
bins have upper and lower bounds. They 
can be created automatically by Excel. 
They can also be set up by the user.

Task: Adjust Histogram Bins
1. Select the Histogram Chart.
2. Go to Chart Format->Current Selection. 
Choose Horizontal Axis from the dropdown list.
3. Go to Chart-> Format-> Current Selection-> 
Format Selection
The Format Axis pane will open.
4. On the Axis Options tab, the Axis Options 
category is open. Under bins, select bin width. 
Enter the value of 10. This means that each bin 
will hold a range of 10 data values.

What Do You See Now? There are more bins to 
show the distribution of the data.

Chart Format->Current Selection->Horizontal Axis
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CREATE A WATERFALL CHART

A waterfall chart is designed to show a running 
total as the initial value is increased or 
decreased over stages. This type of chart 
provides a quick visual of the change in value.

Task: Create a Waterfall Chart
1. Go to the Project Cost Waterfall sheet.
2.  Select cells A1 through B5
3. Go to Insert-> Chart-> Waterfall, Funnel, Stock, 
Surface, or Radar Chart
4. Select Waterfall.

What Do You See? The Waterfall chart shows which 
values are a positive (increase) and which are a 
negative (decrease).
We can see the available funds goes down and even 
below zero before ending in the positive.

Insert-> Chart-> Waterfall, Funnel, Stock, Surface, or Radar Chart
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MODIFY A WATERFALL CHART

A waterfall chart displays the information as 
columns. We can modify the labels to show 
more. In this example we will display the 
Category and the Value.

Task: Modify a Waterfall Chart
1. Select the Waterfall Chart.
2. Go to Chart Format->Current Selection. Choose 
Series 1 Data labels from the dropdown list.
3. Go to Chart-> Format-> Current Selection-> Format 
Selection. The Format Data Labels pane should be 
open on the right.
4. On the Text Options tab, the Label Options 
category is open. Select Category Name and Value.
5. Edit the Separator in the Label Options. 
Click on the Separator drop down. 
Choose (New Line) from the list.

What Do You See Now? The columns are now 
labeled with the Category Name from Column A and 
the Value from Column B. The Names are stacked, 
each separated on its own line.

Chart Format->Current Selection->Series 1 Data Labels
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CREATE A BOX AND WHISKER CHART

A box and whisker chart is used to show the 
distribution of data, highlighting the mean 
(average) and outliers. It's commonly used in 
statistical analysis.

Task: Create a box and whisker chart
1. Go to the Bridge Ages sheet.
2. Select columns A through G.
3. Go to Insert-> Chart--> Insert Statistic Chart-> Box 
and Whisker.

What Do You See? We have a chart showing the 
range of bridge ages. Most fall within a band along 
about 1960 to 1990.
However, this chart doesn't quite match our data set.

Keep going...

Insert-> Chart--> Insert Statistic Chart-> Box and Whisker
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FORMAT A BOX AND WHISKER CHART

Advanced charts have many of the same 
elements as more basic chart styles.
Many of the elements can be modified to be 
appropriate for the data included.
In our data set, we do not have any values 
below 1860s.

Task: Format the Vertical Axis Labels
1. Select the Vertical Axis on the chart.
2. Go to the Chart Elements Chart Icon tool. 
Select Axis Options-> More Axis Options. The Format 
Axis pane will open.
3. Under Axis options, change the minimum value to 
1850.

What Do You See? The Chart was modified. The 
minimum value on the vertical axis is now 1850, not 
1750 the default value recommended by Excel.

Keep going..

Chart Elements-> Axis Options-> More Axis Options
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MODIFY THE BOX AND WHISKER CHART ELEMENTS

By adding details, we have clarified the chart 
and focused the data. Some charts may be 
ready upon insertion accepting the default 
formatting. Other charts, such as this Waterfall 
Chart, benefit from modification.
One last chart modification can be added for 
clarity: a legend. You can add a Legend with 
the Chart Elements or the Chart Design 
Ribbon if you wish.

Task: Modify Chart Elements
The Box and Whisker chart is still selected.
4. Go to Chart Design-> Chart Layouts-> Add Chart 
Element.
5. Add a Legend to the Bottom of the chart.
6. Edit the Chart title: Michigan Bridge Ages

Chart Design-> Chart Layouts-> Add Chart Element.
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SETTING UP THE DATA FOR THE CHART

Some charts require the data organized in a 
particular way. A sunburst chart is a dazzling 
display. However, the data has to be organized in 
a particular way before you can create the chart. 
The data needs to include columns for Year, 
Month, Weather conditions. These columns will  
provide the hierarchy.
Where have we seen this pattern before? Yes, it’s 
the same layout as a PivotTable. Let’s review it.
Data was downloaded from the MDOT website 
and included in the sample file. This data can be 
organized using a PivotTable and then eventually 
displayed as a Sunburst chart.

Task: Review the Data Set
The Advanced Chart sample file is still open. 
1. Go to the Crash_Datasheet.
2. Review the Fields in the Header Row:
ROADNAME, MONTH, DATE, YEAR,…WEATHER

Keep going, please…
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Screen image of the completed sunburst chart

The arrangement of data has an impact on the types of charts that can be created. 
Some charts require the data organized in a particular way.



ORGANIZE THE DATA WITH A PIVOTTABLE

Our sample file also has a PivotTable report of 
the Crash_Data. The PivotTable groups crash 
records by year, month and weather.
This pattern can be displayed as a Sunburst. 
The inner ring is the YEAR. The middle ring is 
the MONTH. The outer ring is the WEATHER.

Task: Review the PivotTable
The Advanced Chart sample file is still open.
1. Go to the Crash_PivotTable sheet.
2. Review the PivotTable Fields:
• Review the Rows: YEAR, MONTH, WEATHER
• Confirm the Value: COUNT of UNITS
3. Review the Report Layout
Go to the PivotTable Design Ribbon and confirm:
• The Report Layout is Tabular.
• There are no Subtotals or Grand Totals.
4. Review the Filters
Go to the MONTH filter in B3. This will be a winter 
report, so the following months are selected: Jan, Feb, 
Mar, only.
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These are the rings for the sunburst chart: 
YEAR, MONTH and WEATHER.



SUNBURST CHART: LINK THE DATA

The data is organized correctly as a PivotTable 
report; however Microsoft Excel does not 
support creating Hierarchy, Statistical or 
Advanced Information Charts, such as Waterfall, 
Funnel or Sunburst, from a PivotTable
There is another way to achieve our goal. We 
can create a linked table and then design the 
Sunburst chart.

Task: Create a Linked Spreadsheet
The Crash_PivotTable sheet is still open.
1. Select A3:D36 on the Crash_PivotTable sheet..
2. Copy the PivotTable labels and data.
3. Go to the Winter Crash Sunburst sheet.
4. Click on cell A1 and PASTE Special.
What Do You See? When select cell A1 and PASTE 
the copied PivotTable, there will be a Clipboard icon.
Click on the Clipboard and choose PASTE LINK.
What Does this Do? The data on the Winter Chart 
sheet will update when the PivotTable is changed.

Home->Clipboard->Paste->Paste Special

MO-201: Microsoft Excel Manage Advanced Charts and Tables 
4.1 Create and Modify Advanced Charts 
4.1.2 Create and Modify Charts including Box & Whisker, Combo, Funnel, Histogram, Map, Sunburst and Waterfall charts

Microsoft Excel for Mobility  Analysts     Page 116

The Label in cell A1 is linked to 
(= Crash_PivotTable!A3) 

the Row Label in the PivotTable.



CREATE THE SUNBURST CHART

A sunburst chart is another chart for showing 
hierarchical data. The sunburst chart shows the 
relationship between the largest categories and 
the data points. Each level of the data hierarchy 
forms a ring on the sunburst chart.

Task: Create a Sunburst Chart
1. Go to the Winter Crash Sunburst sheet.
2. Select column A through D.
3. Go to Insert-> Chart-> Hierarchy Chart-> Sunburst
What Do You See? A new chart will be placed on the 
Winter Crash Sunburst sheet.
• The inner most ring displays the YEARS: 2014, 

2015, 2016, 2017 and 2018
• The second ring has the MONTHS: Jan, Feb, Mar.
• The third ring shows the WEATHER.
The sections of this ring are based on the number of 
crashes. The inner rings size reflects the size of 
sections in this outermost ring.

Keep going..

Insert-> Chart-> Hierarchy Chart-> Sunburst
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UPDATE THE PIVOT TABLE DATA

A PivotTable is a dynamic report. The Table 
can be updated by filtering the Fields.

Task: Filter the PivotTable Report
1. Go to the Crash_PivotTable sheet.
2. Go to the PivotTable Filed List.
3. Filter the YEAR: Select 2016, 2017, 2018.

What Do You See? The PivotTable updated. The 
data has been filtered to show only the YEAR that 
were selected.
What happened to the Sunburst chart?

Keep going….really.

Filter the PivotTable Fields
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MODIFY THE SUNBURST CHART

The Sunburst chart was created with a linked 
reference table. 
When the PivotTable changed, the references 
and the chart updated automatically.

Task: Review the Updated Sunburst Chart
1. The PivotTable was filtered for YEAR.
2. Go to the Winter Crash Rate sheet.

What Do You See? The inner most ring now shows 
the YEARS: 2016, 2017 and 2018.
What Else Do You See? The Sunburst chart does 
not include the rows where there is no data (0).

This really is good work, isn’t it?

Screen image of the updated Sunburst Chart
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UNIT SUMMARY

Superb! In this unit we explored different 
advanced chart types. We looked at the 
relationship between the arrangement of data 
and the chart type. We created different charts 
from the data set and modified them with chart 
tools.
We learned about the different chart types and 
how they display the data visually. We looked at 
treemap, box and whisker, waterfall, histogram, 
and combo charts.
We also explored a process to use a PivotTable 
to transform data to a format conducive to 
creating a Sunburst chart. We learned about 
linked charts.
Nice job.

You may save your work.
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UNIT REVIEW
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1. Which chart type is used to display geographic data?
A. Map chart
B. Treemap Chart
C. Location Chart
D. Combo Chart

2. Which chart types are used to display Hierarchical 
Data (Give all correct answers)
A. Box and Whisker chart
B. Histogram Chart
C. Treemap Chart
D. Sunburst Chart

3. Which chart type shows frequency data?
A. Waterfall Chart
B. Histogram Chart
C. Funnel Chart
D. Combo Chart

4. Which chart type contains two types of charts on 
the same chart?
A. Box and Whisker Chart
B. Treemap Chart
C. Combo Chart
D. Dual Chart

5. Which Chart type shows distribution of data?
A. Waterfall Chart
B. Funnel Chart
C. Histogram Chart
D. Box and Whisker Chart



UNIT REVIEW CONTINUED

Identify the chart type:

1. Treemap

2. Box and Whisker

3. Sunburst

4. Waterfall
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